味噌汁を飲みます

そんなに深く考えて書いていない

2018年9月6日 何もわからん

IPCPでアドレスを配布するローカルプールアドレスの設定は、グローバルコンフィグレーションモードで次のコマンドを入力します。

(config)#ip local pool {<pool-name> | default} <start-ip-address> <end-ip-address>

そして、アドレスを配布する対向ルータが接続されるPPPインタフェースでローカルプールを関連付けます。

(config-if)#peer default ip address pool [<pool-name>]

Cisco IOS のバーチャルアクセス PPP 機能 - Cisco

なんもわからん・・・・ RadiusとPPPoEを同時に使うために使用してるっぽい

IEEE802.1X認証 - Catalystコンフィグ設定

catalyst 2940


aaa new-model

aaa authentication dot1x default group radius

aaa authorization network default group radius

radius-server host  192.168.0.2 key cisco

dot1x system-auth-control

int fastEthernet 0/1

switchport mode access

dot1x port-control auto

dot1x timeout reauth-period 7200

dot1x reauthentication

/ets/raddb/user ユーザを確認

CentOS6 FreeRadius

FreeRADIUSによる認証サーバ - devwiki

sudo system radiusd.service

/etc/raddb/client.conf

client swich{
 ipadd=192.168.0.3
netmask=24
secret=cisco
shortname=C2940M

}

多分、 client IPアドレス{ secret=cisco shortname=C2940M

}

でもよさそう /etc/raddb/client.conf

test Auth-Type:=swich,Cleartest-Password:="pass"

RADIUSはこぴぺ

https://www.infraexpert.com/study/wan14.html

RouterX

Building configuration...

Current configuration : 1309 bytes
!
! Last configuration change at 12:26:38 UTC Thu Sep 6 2018
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterX
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
ethernet lmi ce
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
license udi pid C841M-4X-JSEC/K9 sn FGL213690NL
!
!
username test password 0 test
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
bba-group pppoe PPPOE-GROUP1
 virtual-template 1
!
!
interface Loopback1
 ip address 200.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
 no ip address
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface GigabitEthernet0/3
 no ip address
!
interface GigabitEthernet0/4
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/5
 no ip address
 duplex auto
 speed auto
 pppoe enable group PPPOE-GROUPE1
!
interface Virtual-Template1
 mtu 1454
 ip unnumbered Loopback1
 peer default ip address pool POOL1
 ppp authentication chap
!
interface Vlan1
 no ip address
!
ip local pool POOL1 192.168.0.10
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
 vstack
!
line con 0
 no modem enable
line vty 0 4
 login
 transport input none
!
scheduler allocate 20000 1000
!
end